My 3D Printer's Estimations

in Actifit2 months ago (edited)

I believe now after some observation and experiment that the "pause problem" I had the other day wasn't what I thought it was. The pause menu option on my 3D printer probably does stop running the G-code. I thought it skipped some steps but there might have been an additional problem before the PTFE tube popped out of place.

Something else I've noticed about my 3D printer's display characteristics are the percentage done bar and the estimated time until the print is complete.

The following pictures are from the display readings of a recent large model task.

According to the slicer software that processed the .stl file and the start of the print the estimated time to complete the print was roughly 7 and a half hours. By the time the print was finished almost 10 hours had elapsed.

I used the Tronxy slicer software that came with my 3D printer and I haven't altered the firmware in any way. Why such a large error in calculating the estimated time until completion? I need to look into that.

From the pictures below it is also obvious that the percentage done bar slowly progresses for most of the print but accelerates near the end. According to the percentage done bar the print was only a third done after more than 8 hours but was more than half way done before 9 hours had occurred.

I've noticed the same tendency for other 3D prints I've done.

eta-print1.jpg
Image Source: Personal Photo

eta-print2.jpg
Image Source: Personal Photo

eta-print3.jpg
Image Source: Personal Photo

eta-print4.jpg
Image Source: Personal Photo

This report was published via Actifit app (Android | iOS). Check out the original version here on actifit.io


5057
Daily Activity, Walking

Sort:  

With Klipper I have the same "Pause" problem, and have yet to narrow down why I cannot pause prints. My printer just does a big "sweep" motion , then goes back to printing. It's odd to say the least.

Also, I had the same issue with estimated print times and found there is a setting in Fluidd console (Klippers firmware dashboard)

image.png

That's what it looks like on mine, and setting it to slicer fixed that problem for me.

I hope you have a similar setting which will easily fix it.

As far as the pause, I'm pretty stumped on that one currently.

Keep up the great work man.

Congrats on providing Proof of Activity via your Actifit report!

You have been rewarded 42.85 AFIT tokens for your effort in reaching 5057 activity, as well as your user rank and report quality!
You also received a 1.26% upvote via @actifit account.


Actifit rewards and upvotes are based on your:

  • User rank: which depends on your delegated SP, accumulated AFIT tokens, rewarded post count, recent rewarded activity and owned AFITX.
  • Post score: which depends on your activity count, post content, post upvotes, quality comments, moderator review and user rank.

To improve your user rank, delegate more, pile up more AFIT and AFITX tokens, and post more.
To improve your post score, get to the max activity count, work on improving your post content, improve your user rank, engage with the community to get more upvotes and quality comments.

Actifit is a Hive Witness. If you believe in our project, consider voting for us

rulersig2.jpg
Chat with us on discord | Visit our website
Download on playstore | Download on app store
FAQs | Text Tutorial | Video Tutorial